*.OST Datei kann nicht gesichert werden wenn VSS aktiv ist

NovaBACKUP Professional / Server / Business Essentials
Zuletzt Aktualisiert: Feb 14, 2018 05:14PM PST
Mit diesem Workaround können Sie die *.OST-Datei sichern.
Die Sicherung der *.OST Datei schlägt fehl wenn VSS (gesteuert über die Option "Sicherung geöffneter Dateien aktivieren") in Ihrem Datei-Backup-Job aktiviert ist. Dies betrifft Benutzer, die NovaBACKUP unter Windows Vista (Workstations) und höher und unter Windows Server 2008 und später ausführen. Microsoft hat bestimmte Dateien von Schattenkopien einschließlich der *.OST ausgeschlossen. Standardmäßig verwendet NovaBACKUP VSS (Microsoft's Volume Shadow Copy Service) über die Option "Sicherung geöffneter Dateien aktivieren".  Der Grund, warum *.ost-Dateien in diesem Fall nicht gesichert werden können, ist, dass Microsoft *.ost-Dateien standardmäßig deaktiviert, um mit normalen Methoden gesichert werden zu können. Dies ist eine vorgegebene Einstellung über die Windows-Registrierung. Wegen dieser Voreinstellung kann NovaBACKUP .ost-Dateien nicht sichern wenn im Backup Job die Einstellung "Sichern geöffneter Dateien aktivieren" aktiv ist.

Es wird nicht empfohlen, eine geöffnete *.ost-Datei über Schattenkopien (VSS) zu sichern. Mit diesem Workaround ist es jedoch möglich. Bitte beachten Sie, dass dies in keiner Weise von NovaStor unterstützt wird und das NovaStor Support-Team Sie in diesen Fragen nicht unterstützen kann.

In den meisten Fällen ist es nicht notwendig, eine *.OST-Datei zu sichern. Die OST-Dateien sind lediglich Kopien von Online-Postfächern in Exchange oder Office 365. Es sind zwischengespeicherte Versionen Ihrer Postfachdaten. Wenn diese *.OST-Datei gelöscht werden sollte, wird sie bei der nächsten Verbindung zu Exchange / Office 365 über den Outlook-E-Mail-Client neu erstellt. Deshalb benötigen Sie keine Sicherung dieser *.OST-Dateien.

HINWEIS:
Eine weitere Möglichkeit der Sicherung wäre, die Option "Sicherung geöffneter Dateien aktivieren" in Ihrem Backup-Job zu deaktivieren, Outlook/Skype zu verlassen, so dass die *.ost-Datei nicht mehr aktiv von dieser Software verwendet wird, und dann Ihr Backup zu starten. Mit dieser Konfiguration ließe sich die *.ost-Datei in Ihr Backup einbinden.

Symptome

    Sie verwenden Microsoft Outlook und stellen es so ein, dass eine lokale Kopie Ihrer Objekte auf Ihrem Computer gespeichert wird (Offline Outlook Data File*.ost).
    Sie erstellen mit NovaBACKUP ein Datei-Backup Ihrer Maschine (oder der einzelnen *.ost-Datei) und es wird die Option "Sicherung geöffneter Dateien aktivieren" verwendet.  Diese Option ist standardmäßig aktiviert.

HINWEIS:
Diese Option teilt der Backup-Software mit, dass sie Microsoft VSS (Volume Shadow Copy Services) verwenden soll.
Der Datei-Backup-Job wird erfolgreich abgeschlossen.
    Aufgrund der Microsoft Vorgaben werden Sie vielleicht nicht bemerken, dass die *.ost-Datei in der gespeicherten Sicherung nicht vorhanden ist, dies wird auch nirgendwo im Protokoll erwähnt. Im Falle einer Wiederherstellung können Sie die *.ost-Datei finden.

Ursache

Dies ist eine Einschränkung von Microsoft:
Aufgrund des aktuellen Designs soll die *.ost-Datei nicht gesichert werden, wenn die Backup-Software, die Sie verwenden wollen, Microsoft VSS aktiviert hat (in NovaBACKUP heißt diese Option "Enable Open File Backup" und ist standardmäßig aktiviert), um offene Dateien sichern zu können.  Lesen Sie mehr darüber hier und hier.

Lösung

Gehen Sie wie folgt vor, um das Problem zu umgehen:

1. Öffnen Sie den Windows Registry Editor (Start -> Ausführen -> regedit.exe).
2. Navigieren Sie zum Registrierungsschlüssel HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\BackupRestore\FilesNotToSnapshot
3. Löschen Sie den Unterschlüssel OutlookOST (grün markiert), ODER, wenn Sie den Registrierungsschlüssel nicht löschen möchten, aber trotzdem die Problemumgehung an Ort und Stelle sein soll, überspringen Sie Schritt 4:



4. Alternativ zu Schritt 3 können Sie, wenn Sie den Unterschlüssel "OutlookOST" nicht löschen möchten, auf den Unterschlüssel "OutlookOST" doppelklicken und dann den Datenwert ändern indem Sie eine 1 vor den vorhandenen Daten hinzuzufügen. Dies hat den gleichen Effekt wie das Löschen des Unterschlüssels "OutlookOST".
5. Erstellen Sie eine neue Sicherung. Das Backup sollte die *.ost-Datei enthalten.
6. Nachdem der Sicherungsauftrag abgeschlossen ist, sollten Sie diesmal sehen, dass die *.ost-Datei tatsächlich im Sicherungssatz enthalten ist. Die Datei wird als gesicherte Datei angezeigt und kann somit über die Registerkarte Wiederherstellen wiederhergestellt werden.
Ohne diesen Workaround und abhängig vom Betriebssystem wäre diese *.ost-Datei nicht Teil des gespeicherten Backup-Sets (.NBD-Datei) und würde nicht als Datei aufgelistet.

HINWEIS:
Beachten Sie, dass die meisten granularen Wiederherstellungs-Tools die *.ost-Datei von Outlook 2013 oder neuer nicht verwenden können. Dies gilt auch für das NovaStor Granular Mail Restore (nur verfügbar für NovaBACKUP Business Essentials). Lesen Sie dazu auch die Hinweise im NovaStor Granular Mail Restore PDF Manual. In diesem Fall könnten Sie versuchen, eines der OST-zu-PST-Konvertierungstools im Web zu verwenden, um dann zu sehen, ob Sie diesen Inhalt in Outlook in einem brauchbaren Format erhalten können.  Der NovaStor Support kann Sie jedoch bei keiner dieser Operationen unterstützen, einschließlich der Änderung der Registrierung oder der Verwendung eines Tools mit der *ost-Datei.

HINWEIS:
Beachten Sie bitte, dass das NovaStor Support-Team keinen Support bei der Wiederherstellung einer OST -Datei leisten kann.

Mehr Informationen

Eine OST-Datei oder Offline-Speichertabelle (.ost) ist eine Offline-Outlook-Datei, die von Microsoft Exchange Server und Office 365 verwendet wird. Es ermöglicht Benutzern mit ihren Nachrichten und E-Mail-Daten zu arbeiten, auch wenn der Zugriff auf den Mail-Server nicht verfügbar ist. OST-Dateien werden in zwei Szenarien verwendet: mit dem Cached Exchange Mode von Microsoft Exchange Server und mit dem Outlook Connector für Windows Live Hotmail beim Zugriff auf Hotmail-Mails.

Während E-Mails und andere Daten eines Microsoft Exchange Server-Benutzers normalerweise direkt auf dem Mailserver gespeichert werden, sind OST-Dateien eine verfügbare Option, mit der eine lokale Kopie aller Daten auf dem Computer des Benutzers gespeichert werden kann. Diese Elemente werden dann automatisch synchronisiert, wenn der Zugriff auf den Mailserver wiederhergestellt wird.

Einer der größten Unterschiede zwischen OST-Dateien und den von Microsoft Outlook für die Verwaltung von POP3-, IMAP- und webbasierten E-Mail-Konten verwendeten persönlichen Speichertabellen (.pst-Dateien) besteht darin, dass OST-Dateien im Gegensatz zu PST-Dateien an die Konfiguration des E-Mail-Kontos gebunden sind und nicht einzeln geöffnet oder gesichert werden können.

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