Dies ist ein Workaround für den Fall, dass die *.OST-Datei nicht gesichert werden kann, wenn VSS (gesteuert über die Option "Enable Open File Backup") in Ihrem Dateisicherungsauftrag aktiviert ist. Dies betrifft Anwender, die NovaBACKUP unter Windows Vista und höher für Workstation-Betriebssysteme und Windows Server 2008 und höher für Server-Betriebssysteme einsetzen, da Microsoft bestimmte Dateien von Schattenkopien ausschließt, darunter *.OST. NovaBACKUP verwendet standardmäßig VSS (Microsofts Volume Shadow Copy Service) über eine Option in den Sicherungsaufträgen namens "Enable Open File Backup". Der Grund, warum *.ost-Dateien in diesem Fall nicht gesichert werden können, ist, dass Microsoft standardmäßig verhindert, dass *.ost-Dateien mit normalen Methoden gesichert werden können, und dies ist eine erzwungene Einstellung, die in der Windows-Registrierung vorgenommen wurde. Aus diesem Grund wird die Funktionalität von NovaBACKUP für die Sicherung offener Dateien durch die Entscheidung von Microsoft übertrumpft, die Sicherung von *.ost-Dateien mit VSS zu deaktivieren, wenn diese Einstellung in der Registry vorhanden ist. Es wird nicht empfohlen, eine geöffnete *.ost-Datei mit VSS zu sichern, aber dies ist ein Workaround für diejenigen, die es wünschen. Beachten Sie, dass dies in keiner Weise von NovaStor unterstützt wird und das NovaStor Support Team Sie in diesen Angelegenheiten nicht unterstützen kann.
In den meisten Fällen ist es nicht notwendig, eine *.OST-Datei zu sichern, da diese Dateien lediglich zwischengespeicherte Kopien von Online-Postfächern in Exchange oder Office 365 sind. Da es sich um eine zwischengespeicherte Version Ihrer Postfachdaten handelt, wird diese *.OST-Datei selbst dann wiederhergestellt, wenn Sie sich das nächste Mal über den Outlook-E-Mail-Client mit Exchange / Office 365 verbinden. Das bedeutet, dass Sie keine Sicherungskopien von *.OST-Dateien erstellen müssen, da Sie bei der nächsten Verbindung eine frische Kopie vom E-Mail-Server erhalten.
Symptom
Sie verwenden Microsoft Outlook und stellen es so ein, dass eine lokale Kopie Ihrer Objekte auf Ihrem Computer gespeichert wird (Offline Outlook Data File* => .ost). Sie erstellen mit NovaBACKUP ein Datei-Backup für Ihre Daten (oder der einzelnen *.ost-Datei). Sie haben die Option "Sicherung geöffneter Dateien aktivieren" aktiviert (Diese Option ist standardmäßig aktiviert). Nach der Sicherung stellen Sie fest, dass die .OST Datei NICHT gesichert wurde. NovaBACKUP hat hierzu keinen Fehler gemeldet.
Ursache
Dies ist eine Einschränkung von Microsoft. Aufgrund des aktuellen Designs soll die *.ost-Datei nicht gesichert werden, wenn eine Backup-Software die Microsoft Schattenkopien zur Sicherung nutzt.
Lösung
Gehen Sie wie folgt vor, um das Problem zu umgehen:
1. Öffnen Sie den Windows Registry Editor (Start -> Ausführen -> regedit.exe).
2. Navigieren Sie zum Registrierungsschlüssel HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\BackupRestore\FilesNotToSnapshot
3. Löschen Sie den Unterschlüssel OutlookOST (grün markiert)
ODER
wenn Sie den Registrierungsschlüssel nicht löschen möchten, aber trotzdem die Problemumgehung angewandt werden soll, führen Sie Schritt 4 durch.
4. Alternativ zu Schritt 3 können Sie, wenn Sie den Unterschlüssel "OutlookOST" nicht löschen möchten, auf den Unterschlüssel "OutlookOST" doppelklicken und dann den Datenwert ändern indem Sie eine 1 vor den vorhandenen Daten hinzuzufügen. Dies hat den gleichen Effekt wie das Löschen des Unterschlüssels "OutlookOST".
5. Erstellen Sie eine neue Sicherung. Das Backup sollte die *.ost-Datei enthalten.
6. Nachdem der Sicherungsauftrag abgeschlossen ist, sollten Sie diesmal die *.ost-Datei im Sicherungssatz finden. Die Datei wird als gesicherte Datei angezeigt und kann somit über die Registerkarte Wiederherstellen wiederhergestellt werden.
Ohne diesen Workaround und abhängig vom Betriebssystem wäre diese *.ost-Datei nicht Teil des gespeicherten Backup-Sets (.NBD-Datei) und würde nicht als Datei aufgelistet.
HINWEIS:
Beachten Sie bitte, dass das NovaStor Support-Team keinen Support bei der Wiederherstellung einer OST -Datei leisten kann.
Mehr Informationen
Eine OST-Datei oder Offline-Speichertabelle (.ost) ist eine Offline-Outlook-Datei, die von Microsoft Exchange Server und Office 365 verwendet wird. Es ermöglicht Benutzern mit ihren Nachrichten und E-Mail-Daten zu arbeiten, auch wenn der Zugriff auf den Mail-Server nicht verfügbar ist. OST-Dateien werden in zwei Szenarien verwendet: mit dem Cached Exchange Mode von Microsoft Exchange Server und mit dem Outlook Connector für Windows Live Hotmail beim Zugriff auf Hotmail-Mails.
Während E-Mails und andere Daten eines Microsoft Exchange Server-Benutzers normalerweise direkt auf dem Mailserver gespeichert werden, sind OST-Dateien eine verfügbare Option, mit der eine lokale Kopie aller Daten auf dem Computer des Benutzers gespeichert werden kann. Diese Elemente werden dann automatisch synchronisiert, wenn der Zugriff auf den Mailserver wiederhergestellt wird.
Einer der größten Unterschiede zwischen OST-Dateien und den von Microsoft Outlook für die Verwaltung von POP3-, IMAP- und webbasierten E-Mail-Konten verwendeten persönlichen Speichertabellen (.pst-Dateien) besteht darin, dass OST-Dateien im Gegensatz zu PST-Dateien an die Konfiguration des E-Mail-Kontos gebunden sind und nicht einzeln geöffnet oder gesichert werden können.