Here is the description of the bug along with a resolution:
Cause
The "CMon Server Administration" desktop application (which can be launched from the Start Menu) incorrectly updates the service configuration and application settings in the database, preventing agents from being able to reconnect to the Management Server.
If you open the "CMon Server Administration" desktop application, click on Save, and then restart the "Management Server" windows service, it will prevent agents from reconnecting.
Resolution
1. system.serviceModel.services.config
The desktop application incorrectly adds an extra path to the baseAddress
in system.serviceModel.services.config
.
For example, in C:\Program Files (x86)\NovaStor\NovaBACKUP Central Management Console\Service\system.serviceModel.services.config
<add baseAddress="net.tcp://localhost:4502/AgentService" />
If you manually modify the file, remove the last segment /AgentService
, and restart the "Management Server" windows service, the agents will start to reconnect successfully.
For example, this is the correct value for the baseAddress
:
<add baseAddress="net.tcp://localhost:4502/" />
You will need to fix the configuration file in at least two places.
2. ManagementServer
Database
The desktop application removes the hostname / IP Address from the HubConnectionUrl
value in the application_settings
database table.
For example, the SettingValue
for the HubConnectionUrl
SettingName should be
http://<hostname or IP Address>:80/ManagementServer/signalr
Using SQL Server Management Studio, right-click the the application_settings
table in the ManagementServer
database and choose "Edit Top 200 Rows".