This is a workaround for failure to back up *.OST file if VSS (controlled via the "Enable Open File Backup" backup job option) is enabled in your file backup job. This will affect users running NovaBACKUP under Windows Vista and above for workstation OS's and Windows Server 2008 and later for Server OS's, since Microsoft chose to exclude certain files from shadow copies including *.OST. By default NovaBACKUP uses VSS (Microsoft's Volume Shadow Copy Service) via an option in the backup jobs called "Enable Open File Backup". The reason why *.ost files will fail to backup in this case is that by default Microsoft disables *.ost files from being able to be backed up using normal methods and this is a forced setting that they have placed in the windows registry. Because of that, NovaBACKUP's functionality for backing up open files is being trumped by Microsoft's choice to disable .ost files from being able to be backed up with VSS if that registry setting is in place. It is not recommended to attempt to backup an open *.ost file using VSS, however this is a workaround for those that want it. Know that this is not supported in any way by NovaStor and the NovaStor Support team cannot support you on these matters.
In most cases the need to backup a *.OST file is not necessary as these files are merely cached copies of online mailboxes in Exchange or Office 365. Since it is a cached version of your mailbox data even if that *.OST file were to be deleted it will be rebuilt the next time you connect to Exchange / Office 365 via the Outlook email client. This means that you do not need to back up *.OST files since you will get a fresh copy from the email server the next time you connect.
NOTE: It would be better practice to disable the option "Enable Open File Backup" in your backup job and then exit out of Outlook / Skype so that the *.ost file is no longer actively being used by that software and then complete your backup with those programs not running, to be able to have the *.ost file contained in your backup set.
Symptoms
- You are using Microsoft Outlook and set it to keep a local copy of your items on your computer (Offline Outlook Data File*.ost).
- You create a file backup of your machine (or the single *.ost-file) using NovaBACKUP and the backup job option for "Enable Open File Backup" is being utilized. This option is a default enabled option. NOTE: The Enable Open File Backup option tells the backup software that it should utilize Microsoft VSS (Volume Shadow Copy Services). Since Microsoft has a limitation due to the current design the *.ost-file is not supposed to be backed up if VSS is utilized.
- The file backup job completes successfully.
- You may not notice that even though the file backup job completed succesfully the *.ost-file is not present in the stored backup and it also is not mentioned in the log anywhere that it was backed up. The *.ost-file is not present in the backup. If you look closely at the log output for the backup job, the log won't show that the .ost-file was present in the backup set, meaning it was never stored in the backup. The *.ost-file cannot be located if you attempt to Restore that backup set, it won't be a listed file to be able to restore.
Cause
This is a limitation of Microsoft: due to the current design the *.ost-file is not supposed to be backed up if the backup software that you are attempting to utilize has Microsoft VSS enabled (in NovaBACKUP this option is called "Enable Open File Backup" and by default it is turned on) to be able to backup open files. Read more about this here and here.
Solution
Do the following to work around the issue:
- Open the Windows Registry Editor (start -> run -> regedit.exe)
- Navigate to the registry keyHKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\BackupRestore\FilesNotToSnapshot
- Delete the OutlookOST subkey (marked in green), OR if you do not want to delete the registry key but you still want the workaround to be in place skip to Step 4:
- Alternatively to Step 3, if you don't want to delete the "OutlookOST" subkey, but you still want the workaround to be in place, you can double-click the "OutlookOST" subkey and then modify the data value to add a 1 in front of the existing data so the value data would be: 1$UserProfile$\AppData\Local\Microsoft\Outlook\*.ost. This will have the same effect as deleting the "OutlookOST" subkey.
- Create a new backup. The backup should contain the *.ost-file.
- After the backup job has completed you should see that this time after completing that the *.ost-file is actually included in the backup set, and when viewing the backup log that this file is shown as a file that was backed up, and that file is now a listed file to be restored via the Restore tab. Without this workaround in place and depending on the OS, this *.ost file would not be part of the stored backup set (.NBD file) and would not be listed as a file that could be restored, if at the time of backup that the *.ost-file was in use by Outlook / Skype applications at the time of backup.
- NOTE: Keep in mind that most granular item recovery tools cannot utilize *.ost-file if the version of Outlook is Outlook 2013 or newer, including the NovaStor Granular Restore tool that is available for NovaBACKUP Business Essentials customers. The NovaStor Granular Restore tool cannot utilize a *.ost-file from Outlook 2013, or Outlook 2016, read the Note in the NovaStor Granular Restore PDF Manual linked here for that info. In this case you could attempt to utilize one of the OST to PST conversion tools out there on the web to then see if you can get that content in to Outlook in a usable format. However, NovaStor Support cannot support you on any of these operations including modifying the registry or using a tool with the *ost-file.
NOTE: Be aware that the NovaStor Support team cannot provide support if you need help on restoring an *.ost-file content from your backups, or importing or re-using the restored *.ost-file in any version of Outlook.
More Information
An OST file, or offline storage table (.ost) file, is an offline Outlook Data File used by Microsoft Exchange Server and Office 365 that enables users to work with their messages and mail data even when access to the mail server isn't available. OST files are used in two scenarios: with Microsoft Exchange Server’s Cached Exchange Mode and with the Outlook Connector for Windows Live Hotmail when accessing Hotmail mail.
While a Microsoft Exchange Server user’s e-mails and other data items are normally saved directly on the mail server, OST files are an available option that enable a local copy of all the data to be stored on the user’s computer. These items are then automatically synched when access to the mail server is restored.
One of the biggest differences between OST files and the personal storage table (.pst) files used by Microsoft Outlook for managing POP3, IMAP and web-based mail accounts is that unlike PST files, OST files are tied to the mail account configuration and cannot be opened or backed up individually.